News

Mar 20, 2015
OpenSSL vulnerability patches

On March 19th a few patches have been released to fix vulnerabilities in the OpenSSL code library. This library is used by web servers to encrypt communication between server and PC. MCX is currently investigating whether there are servers vulnerable. We will keep you updated via the web site.

If no-one has contacted you then your servers are not vulnerable.

If you have additional questions please contact MCX at +31555260670 and ask for our Security Officer.

Help us share this
Share Share Share Share Share